https://argens.ru/Lazy Velo Spoiler - плагин спойлеров для контента

Lazy Velo Spoiler - плагин спойлеров для контента

Тип
Плагин
Совместмость
Joomla 2.5  Joomla 3.0

«Lazy Velo Spoiler» является эволюционной версией плагина «pb_spoiler» от beliyadm.

Главные особенности (опции) нашего плагина:
1. Подгрузка изображений только для открытых и открывающихся спойлеров. Это позволяет оперировать большими массивами изображений не увеличивая нагрузку на сервер и не замедляя загрузку страницы.
На данный момент механизм динамической подгрузки выглядит по-разному для jQuery и MooTools вариантов (в первом случае спойлер сразу открывается, а вместо изображений появляются заглушки в виде прелоадеров, во втором – спойлер открывается после загрузки всех изображений внутри себя, а индикатор загрузки возникает рядом с заголовком спойлера).

2. Опции jQuery и MooTools максимально унифицированы, в результате чего пользователь может безболезненно выбирать любую версию, не теряя настроек и функционала. 

3. Параметр «оставлять открытыми» вынесен внутрь синтаксиса плагина, что позволяет создавать произвольные комбинации закрытых/открытых спойлеров для каждой страницы сайта. 

4. Языковые константы вынесены в ini-файлы, что позволяет легко переводить плагин на нужный язык. В настоящий момент доступны русская и английская версия.

На сегодня плагин существует только для Joomla версии 1.5.20 и выше.  При выборе MooTools-версии необходимо активировать системный плагин MooTools-upgrade.

Правила использования:
В текст статьи необходимо вставить следующую конструкцию:

Код:
{spoiler title=Заголовок opened=1}Скрытый текст{/spoiler}

где opened - состояние спойлера при загрузке страницы, 1 - открыт, 0 - закрыт.

В работе помогали:
effrit - доработка mootools-спойлера, английская локализация, свежие идеи
staticlight - английская локализация
Lexx - версия для Joomla 1.7
al-teen - стилевое оформление спойлеров

Системные требования для joomla 1.5  - версия Joomla не менее 1.5.22 и включенный плагин mootools upgrade.

Системные требования для joomla 1.6, joomla 1.7 - особых требований нет. 
 
Выпущен плагин Lazy Velo Spoiler для Joomla 3.0. Скачать можно там-же, версия плагина - 1.1.
Смотрите ошибки в консоли firebug или подобном инструменте.
Николай
Добрый день! Подскажите с проблемкой. На разных сайтах joomla 3 ведет себя по разному, в одном случае не раскрывается вообще, в другом случае все время раскрытый, но на кнопку закрыть реагирует. В настройках все указывал, как требовалось.
comments powered by HyperComments